Set Home| Set Favorite|

WPS Office Forum

 Forgot password?
 Register
Search
View: 11840|Reply: 17

AltGr not working

[ Promote this link! ]
Post time: 2012-08-19 14:22:08
| Show all posts |!read_mode!
I've installed the Free version on Windows XP SP3 today and trying to use AltGr key to input some special characters. Strangely, it doesn't work (silently ignored) when I am editing text in Writer or a cell in Spreadsheets. At the same time, in font name, style name and other fields like that AltGr works fine. It also works in all other applications I've tried. Is there some setting I need to change to make it work where I really need it to?
Reply

Use magic Report

Post time: 2012-08-28 09:47:49
| Show all posts
Will it work when you change another input method?
Could you please provide your device mode to us?
Also the input method.
We will log it and feedback to the related R&D department.
We will take it seriously and will response to you once it is available.
 Author| Post time: 2012-08-28 21:28:30
| Show all posts
Sorry, I'm not quite sure I understand the question. If by "input method" you mean keyboard layout, then I was trying it for Russian with Ilya Birman's typography layout (I can provide the download link for it if necessary). And what do you mean by the "device mode" for PC?

As I already wrote, the layout itself works fine, keyboard drivers are installed and all AltGr combinations work fine everywhere except KSO (just a few symbols to demonstrate: «»≠—).

I don't think that this functionality requires any specific support from the application, as it seems to be an OS feature supported by keyboard drivers, but it looks like KSO somehow intercepts and blocks it for some reason (perhaps trying to handle according to some unknown built-in rules?).
Post time: 2012-11-05 11:20:59
| Show all posts
I have the same problem with a windows vista machine. All the Alt Gr characters just don't get written. It works everywhere else, also e.g. in the font name indicator. @£$€{[]}

My keyboard layout is a standard Danish one.

Also, it seems that the Alt + xxxx ascii character codes are not right. I often write in French: ç is Alt + 0231, but in KSO that Ascii code yields O!! So I can't use the ascii codes to write @£$€{[]} etc.

Would be happy to see a solution - I'm otherwise very enthusiastic about finding a word processing software that looks and behaves like my old beloved Word 2003. But I won't consider bying the license if this problem is permanent.
Post time: 2012-11-12 21:24:54
| Show all posts
Same issue here.
My keyboard layout is Hungarian. Windows 7 64bit.
Keyboard and AltGr is working fine in other applications.
Post time: 2013-02-27 06:32:36
| Show all posts
Hi all,

This bug indeed exists current version.

Hope the bug will be fixed next version.
Post time: 2013-03-01 17:41:55
| Show all posts
AltGr also not work on my Kingsoft Office...

Windows 8 x64
Keyboard: Turkish.
Post time: 2013-03-02 23:10:54
| Show all posts
Hi I'm on Windows 7 32 bit and AltGr is not working with my Turkish Keyboard too.

Moreover in Writer , Change Case  icon is missing.
Post time: 2013-03-04 09:33:06
| Show all posts
Hi mcmstar,

To change case, please see below method: In the 'Format' menu, choose 'Convert Case' option, and then, a Convert Case dialog box will appear, you can choose the case you want to change.

Please see picture 1 and 2.

!attach_nopermission_notice!

You have to Login to download or view attachment(s). No Account?

x
Post time: 2013-03-05 10:34:44
| Show all posts
Hi Kristy, thank you very much.

I have another problem in Writer and I'll write it to the related forum section.
You have to log in before you can reply Login | Register

Points Rules

Dark room|Mobile|Archiver|WPS Office   

2019-07-19 00:14 GMT+8 , !processed_in! 0.072518 !seconds!, 10 !queries! .

Powered by Discuz! X3.2

Release 20151208, © 2001-2019 Comsenz Inc.

MultiLingual version, Rev. 469, © 2009-2019 codersclub.org

!fastreply! To Top !return_list!