Set Home| Set Favorite|

WPS Office Forum

 Forgot password?
 Register
Search
View: 6312|Reply: 10

Dates formatting

[ Promote this link! ]
Post time: 2013-10-14 22:25:03
| Show all posts |!read_mode!
Hi all,

I'm from Europe so I enter dates in the European format as such: DD-MM-YYYY.

Now here's the problem:

I've set this up in the cell properties to display dates as DD-MM-YYYY and it will display them as such but it will NOT let me enter them into a cell as such. For some reason it think's I'm inputting MM-DD-YYYY and I do not for the life of me understand why that is nor how I can tell it how to see the date format (in short, while to me 12-01-2014 is January 12th 2014, to the program it's December 1st 2014). Can anyone give me a helpful suggestion? I can't seem to find a thing about how input should be handled by the program.

I don't want it to think for me: if I put something in that could be a valid date I want Spreadsheet to leave it alone and just accept it for what it is. The cell property already tells the program how to treat it.

Thanks in advance!
Reply

Use magic Report

 Author| Post time: 2013-10-14 22:33:08
| Show all posts
To add more information: I'm using KSO2013.
Post time: 2013-10-14 23:49:55
| Show all posts
Edited by Ferrick at 2013-10-15 01:53
Warlord1981NL replied at 2013-10-15 00:33
To add more information: I'm using KSO2013.

Hi, I also use the European settings here in Australia dd-mm-yyyy and do not experience this problem.  The only time this occurs is if you're using the Visual Basic Editor where all dates must be input using the US format.  One thing that will alter the input is if your Windows settings are for another language.  If I set my computer to US time and date formats, I get the problem you are describing. Perhaps you could check your settings in the Control Panel.  At present I can't think of anything else that may be causing the problem.
Are you using the Free or Professional Version?

Post time: 2013-10-18 15:38:21
| Show all posts
Warlord1981NL replied at 2013-10-14 22:33
To add more information: I'm using KSO2013.

Kingsoft office 2013 support Europe date format. You need set it.
Here is guide about how to set dd/mm/yyyy date formats in kingsoft office
http://www.ksosoft.com/spreadshe ... t.html#.UmFIkW2miSo
Hope it is useful.
Post time: 2013-10-28 12:37:48
| Show all posts
hi
i dont think thats  what original user means - i too am having this problem
for example - all my regional settings are correct - i checked for UK dd/mm/yyyy
ok - i go to a cell - lets presume i want to enter the date "5th day of march 2010"

what i and the other users would like to do is this enter as follows (in the proper format)
05/03/2010 (press enter)
if you do this in a spreadsheet it should show 05-March-10 when pressing ENTER

BUT it does NOT - it shows 03-May-10 - it should show the date EXACTLY as you type it in but it does NOT
here is what we want - when the user types in 05/03/2010 thats exactly what they should see when he presses ENTER - but they see 03/05/10 or 03-may-10 (depending on format)

the key issue here is that :-
EXACTLY what we type should match EXACTLY what we  see when we press ENTER
but it doesnt if i type 05/03/2010 it becomes 03/05/2010 when i hit ENTER - this is INCORRECT
please help ?
Post time: 2013-10-28 21:09:42
| Show all posts
dmm1000 replied at 2013-10-28 14:37
hi
i dont think thats  what original user means - i too am having this problem
for example - all my  ...

Hi, I have checked the dates on both the Free and Professional versions, the latest releases and the only way I can get the behavior you describe is if the Format settings in the Control panel are not correct. There are two settings, Location and Format that should be set.

Are you using the latest versions?
Post time: 2013-10-29 18:12:13
| Show all posts
ferrrick you could be right - i will double check .......just in case
Post time: 2013-10-29 18:48:01
| Show all posts
here are my settings in the attachment - and also at the link below i have made a video on phone to show problem
https://plus.google.com/photos/116651025112044080683/albums/5940232077911324801/5940232259574667874?banner=pwa&pid=5940232259574667874&oid=116651025112044080683




!attach_nopermission_notice!

You have to Login to download or view attachment(s). No Account?

x
Post time: 2013-10-29 20:05:06
| Show all posts
dmm1000 replied at 2013-10-29 20:48
here are my settings in the attachment - and also at the link below i have made a video on phone to  ...

Hi, Just testing something here. It appears that this is Windows 7.  Can you go to the Control Panel and change the format to English (Australia) and see if the problem stops. I find that with your settings I get the same problem.

Cheers!
Ferrick
Post time: 2013-10-29 22:01:10
| Show all posts
thanks Ferrick - UK and Australia are fine
you just need to adjust the software in the next release to change Ireland to match their settings (UK and Australia) and we are good to go  ;)
thanks
You have to log in before you can reply Login | Register

Points Rules

Dark room|Mobile|Archiver|WPS Office   

2019-08-17 22:03 GMT+8 , !processed_in! 0.082266 !seconds!, 10 !queries! .

Powered by Discuz! X3.2

Release 20151208, © 2001-2019 Comsenz Inc.

MultiLingual version, Rev. 469, © 2009-2019 codersclub.org

!fastreply! To Top !return_list!